Order imports are back to normal operation. If you experience further issues, please reach out to support@neatoscan.com for assistance.
Posted Apr 21, 2025 - 13:20 UTC
Monitoring
Developers have been working on this issue and we are seeing improvement in orders processing normally. Monitoring to make sure there is no regression.
Posted Mar 27, 2025 - 22:08 UTC
Investigating
We are currently investigating an issue which is causing stopped order processing primarily for eBay and Amazon, although other marketplaces may also be affected. We will update this page as we identify the issue and establish an ETA to fix. Thank you for your patience.
Posted Mar 26, 2025 - 21:50 UTC
This incident affected: Order Processing (Import).