Mass Server Related Outages

Incident Report for Neatoscan

Resolved

This specific issue and cause has been resolved. Clients may be impacted by a separate issue which will be updated shortly.
Posted Aug 18, 2025 - 09:16 EDT

Update

Additional Info: affected clients may see longer than usual app to marketplace times as the servers get caught up. This behavior is normal and should normalize in due course.
Posted Jul 25, 2025 - 17:35 EDT

Update

All affected systems should be operating normally. We will continue to monitor and will update this space with the all clear once we're certain no further anomalies for this issue will occur.
Posted Jul 25, 2025 - 17:29 EDT

Update

We are continuing to monitor but have made progress with this issue. General operations are restored, however, some clients may be experiencing anomalies with order processing, packing slips and order status updates. We are addressing these specific issues and will update this space when progress is made.
Posted Jul 25, 2025 - 09:33 EDT

Update

Progress is being made to fully resolve this issue. Further restoration work is progressing through the evening and will be updated here once complete.
Posted Jul 24, 2025 - 18:01 EDT

Monitoring

We have implemented a fix and are now verifying all systems.
Posted Jul 24, 2025 - 17:00 EDT

Update

Servers have been restored, but issues are still persistent. Continuing to troubleshoot the root cause.
Posted Jul 24, 2025 - 14:05 EDT

Identified

We have identified a potential cause of the server issues. The fix involves restarting a server, which will cause the NeatoScan application to be inaccessible for 15 minutes or so. We will update this status page once the application is once again operational.
Posted Jul 24, 2025 - 13:39 EDT

Investigating

Several client are continuing to have issues with live lookup and others are unable to access the application. We are continuing to investigate. Thank you for your patience.
Posted Jul 24, 2025 - 13:23 EDT

Update

While the overall issue seems resolved, there are some clients still having challenges with Live Lookup. We are continuing to monitor and investigate.
Posted Jul 24, 2025 - 13:16 EDT

Monitoring

Issue was identified and resolved. Currently monitoring to make sure there is no regression. If you continue to experience issues, please restart the app and retry. If issues continue, please contact our support team.
Posted Jul 24, 2025 - 12:54 EDT

Investigating

We are investigating server-related outages affecting all parts of the NeatoScan system including Live Lookup, log ins and other parts of the software. We are making this our top priority and will alert this space once resolved. Thank you for your patience.
Posted Jul 24, 2025 - 12:28 EDT
This incident affected: Listing, Order Processing (Import), Shipping/Order Fulfillment, and Reporting.