Reporting Issues

Incident Report for Neatoscan

Resolved

Reporting issues caused by last week's server maintenance have been resolved. Please reach out to our support team if you continue to experience challenges.
Posted Aug 21, 2025 - 10:50 EDT

Identified

We have identified an issue which is causing NeatoScan Reporting to be inoperative or inaccessible. We are working to resolve this challenge and will update this space as we make progress. Thank you for your patience.
Posted Aug 18, 2025 - 09:18 EDT
This incident affected: Reporting.