Degraded Performance and Freezes

Incident Report for Neatoscan

Resolved

The slowdowns and freezes have been resolved. Please restart the software if still experiencing issues and reach out to support in the case they persist after a restart.
Posted Apr 14, 2025 - 15:14 UTC

Investigating

We are currently investigating reports of slow load times as well as constant freezes in the software.
Posted Apr 14, 2025 - 13:12 UTC
This incident affected: Listing, Order Processing (Import), and Shipping/Order Fulfillment.