We are continuing to monitor this issue. While most organizations are no longer experiencing this challenge, we are receiving sporadic reports of repricing not working for individual accounts. We will continue to monitor and investigate.
Posted Jun 12, 2025 - 13:26 UTC
Monitoring
We have deployed additional fixes to improve the repricing process over the past few weeks. We are seeing enhanced repricing performance and expect continued improvements for most customers. This work is ongoing and remains a priority.
This ticket will be set to monitoring as work continues.
Posted Jun 06, 2025 - 13:55 UTC
Update
We have deployed additional fixes to improve the repricing process over the past few weeks. We are seeing enhanced repricing performance and expect continued improvements for most customers. This work is ongoing and remains a priority.
This ticket will be set to monitoring as work continues.
Posted Jun 06, 2025 - 13:55 UTC
Update
While we are seeing improvement for some clients, others are still experiencing degraded performance in repricing. We are continuing to work to resolve the issue for all clients and restore full functionality.
Posted May 21, 2025 - 13:20 UTC
Identified
Although we have seen some improved activity we are still working on a permanent fix for this issue. We will continue to work toward resolution and update this incident with information as it becomes available.
Posted May 15, 2025 - 18:13 UTC
Monitoring
A fix has been implemented and we are currently monitoring it's performance. Smaller accounts may see repricing normalizing within an hour or so, larger accounts may take several hours to update. We will continue to monitor internally and externally and update this space when we have definitive results. Thank you for your patience in this matter.
Posted May 12, 2025 - 13:42 UTC
Update
No further updates to report. Next update to be provided tomorrow afternoon (EST) with any progress made.
Posted May 07, 2025 - 21:47 UTC
Update
Our developers are earnestly continuing to investigate the root cause of this issue. We will update this alert tomorrow afternoon, or when any new information becomes available.
Posted May 05, 2025 - 22:12 UTC
Update
We have found potential causes for the outages and are continuing to investigate solutions. We will update the status at latest before end-of-day today with any new information or as it becomes available. Thank you for your continued patience.
Posted May 05, 2025 - 14:42 UTC
Investigating
Some, but not all, NeatoScan Books clients are experiencing outages or slowdowns in repricing. We are investigating these intermittent outages and will provide updates shortly.
Due to the variable nature of this issue, if repricing has not run for your organization, or you're experiencing abnormal delays, please alert our Support Team at support@neatoscan.com to make sure we are aware.