Amazon API Critical Issue

Incident Report for Neatoscan

Update

The initial release deployed has been successful. We are working on additional fixes and monitoring Amazon API status. Continue to keep your Amazon account on vacation mode until further notice.

Updates will be shared as soon as more information is available.
Posted Aug 22, 2025 - 16:05 EDT

Update

The initial release deployed has been successful. We are working on additional fixes and monitoring Amazon API status. Continue to keep your Amazon account on vacation mode until further notice.

Updates will be shared as soon as more information is available.
Posted Aug 21, 2025 - 19:44 EDT

Update

We have identified a critical issue with our Amazon API integration that requires an emergency update today. As a result, Amazon order processing may be impacted.

We are working to resolve the issue, but we do not yet have an estimated timeline for when the integration will be fully restored.

Updates will be shared as soon as more information is available. PLEASE KEEP YOUR AMAZON ACCOUNTS ON VACATION MODE.

We understand how important timely order processing is to your business, and we sincerely apologize for the disruption this may cause. Thank you for your patience as we work to restore functionality as soon as possible.
Posted Aug 21, 2025 - 16:02 EDT

Update

CLARIFICATION: We would like to reiterate that all marketplaces are functional with the exception of Amazon. We are continuing to test the fix for Amazon and will update this space as progress is made. Thank you for your patience and we apologize for any confusion.
Posted Aug 21, 2025 - 10:38 EDT

Update

Our engineering team is actively testing a fix to address the issue.

At this time, we strongly advise that you continue to keep your Amazon account(s) in vacation mode until further notice. This precaution will help protect your account and minimize potential order issues while testing is underway.

We will share another update as soon as we have confirmed results from testing. Thank you for your continued patience and understanding as we work to fully resolve this issue.
Posted Aug 19, 2025 - 19:14 EDT

Identified

As we ready to deploy fixes for today's incidents, Amazon should remain on vacation mode until further notice. However, vacation mode can be removed from all other marketplaces. We will update you with more information as it becomes available.
Posted Aug 18, 2025 - 15:59 EDT

Update

We are currently experiencing a failure with our main database server that is affecting most customers and causing service inoperability. Until the issue is resolved, we strongly recommend placing your accounts in vacation mode to avoid disruptions to your accounts and minimize order issues.

Our engineering team is actively working to identify the root cause. We expect to provide a detailed update by end of day and will share urgent updates as soon as we have more information.
Posted Aug 18, 2025 - 11:52 EDT

Investigating

We are currently investigating a maintenance recovery issue affecting some clients. Users may have one or all of the following challenges: unable to log into the app, WebApi errors and, possibly, order processing issues. We are diligently working to resolve these issues as we recover from the maintenance this weekend. We will update this space as progress is made and thank you for your patience.
Posted Aug 18, 2025 - 09:22 EDT
This incident affects: Listing, Order Processing (Import), Shipping/Order Fulfillment, and Amazon API.